5.15 升级操作系统内核

在Linux使用过程中,由于系统自带内核版本太老,或者存在一定程度的硬件支持缺陷,用户往往会遇到诸如无线网卡信号不佳、网络连接不稳定、硬件设备无法识别和使用等问题。
如果您遇到了这些问题,可能就需要安装使用新版本内核来进行排查。
尽管新内核有可能解决部分硬件兼容问题,但是也有很大几率导致现有的闭源驱动无法正常使用。
请只有在当涉及硬件驱动问题而走投无路的时候,才更换内核。
Linux内核和上层应用的耦合程度较低,所以一般不同发行版的内核可以通用。经测试,Ubuntu的内核可以直接拿来给Deepin使用:
https://kernel.ubuntu.com/~kernel-ppa/mainline/
寻找你想使用的内核版本,例如5.4.28:
https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.4.28/
一般只下载带"all"和"generic"字样的包,例如:
linux-headers-5.4.28-050428_5.4.28-050428.202003250833_all.deb
linux-headers-5.4.28-050428-generic_5.4.28-050428.202003250833_amd64.deb
linux-image-unsigned-5.4.28-050428-generic_5.4.28-050428.202003250833_amd64.deb
linux-modules-5.4.28-050428-generic_5.4.28-050428.202003250833_amd64.deb
单独放在一个目录中,终端下执行:
sudo dpkg -i *.deb
重启,然后选择新内核引导项即可。

Copyright © DOSU community 2020 all right reserved,powered by Gitbook该文章修订时间: 2020-09-12 12:06:10

results matching ""

    No results matching ""